Drobo Forums
Drobo 5c is very very slow - Printable Version

+- Drobo Forums (http://www.drobospace.com/forums)
+-- Forum: Drobo (/forumdisplay.php?fid=1)
+--- Forum: Direct Attached Storage (DAS) Forums (/forumdisplay.php?fid=62)
+--- Thread: Drobo 5c is very very slow (/showthread.php?tid=147423)


Drobo 5c is very very slow - hastor - 01-10-2017 07:58 PM

I just got my Drobo 5C, I'm using it for the first time. It is connected to a USB 3.1 port. I'm copying a file that I've copied over the same port to an external HDD at 80MB/s recently (limited by the speed of the external drive). Copying to the Drobo, I'm getting 15-20MB/sec. It is even dipping to 8MB/s and occasionally going down to zero and sitting there for a second before going back up. I'm testing by copying a 50GB file.

I understand they do some self-optimizing when they are new, but I don't think it should be THIS slow. Even in the Drobo Dashboard it shows Write Throughput of 18MB/sec. I would question whether it was getting a proper usb 3.0 connection but even usb 2.0 can do better than this.

I'm running 4 drives - 8TB, 5TB, 750GB, and 250GB. I'll be adding another 5TB once I've backed up the contents on it to the current drives, and will be replacing the 250GB with another 8TB in a month or so. I was just using what I had for now until I can afford bigger drives.

Any advice? At least I can return it if I don't find a solution or see a major improvement in 2 days.

Just a small update - it's been a couple hours since I posted this (and then it had already been long enough to drive me to post about it) and no change. It maybe hits zero less often, but still hovers around 18-21MB/s. I've seen it barely hit 23MB a couple of times, but never once 24 or higher. I even left it unused but on and connected for at least 30 mins to let it catch up with any housekeeping, but it didn't help.


RE: Drobo 5c is very very slow - AzDragonLord - 01-11-2017 05:10 AM

many things could slow your throughput... on the Drobo or on your computer. Your 8TB drive wouldn't happen to be an "archive" drive would it? What are your drive model numbers?


RE: Drobo 5c is very very slow - hastor - 01-11-2017 08:38 AM

(01-11-2017 05:10 AM)AzDragonLord Wrote:  many things could slow your throughput... on the Drobo or on your computer. Your 8TB drive wouldn't happen to be an "archive" drive would it? What are your drive model numbers?

While I can't get the drive model right now as I'm not home, I can confirm that the same drive, when attached to a USB 3.0 adapter, gets blazing fast speeds. Shouldn't it be able to do the same via the Drobo? It is a Seagate 5400RPM purchased this year.


RE: Drobo 5c is very very slow - Paul - 01-11-2017 05:53 PM

hi hastor, when you get a chance to follow up with some more info for dragon would you also be able to have a quick look in dashboard, to click on each bay (and to essentially bring up additional info or dropdown info) about each drive, to see in case one of the drives is showing any warning or healed messages?

while it might seem that it is still "early days", as far as the drobo goes, and speeds should pick up (for example in my sig), though am just wondering just in case one of the smaller, possibly older, drives was encountering a few niggles and slowing things down overall?

interestingly enough, i also just recently posted some more info about possible slowdowns on this thread, (who was by a user who's large file was very quick, though smaller files were slower than expected)
http://www.drobospace.com/forums/showthread.php?tid=147405


RE: Drobo 5c is very very slow - hastor - 01-11-2017 06:04 PM

I've tried it with only the two larger drives in the upper bays, and with only the two smaller drives in the lower bays. Even in those situations I got a steady 15MB/s. So it doesn't seem to be a bad drive or bay. When clicking on each bay, they all show health as Good. Additionally, I've tested all of these drives individually using an SATA to USB 3.0 adapter and they were many times faster on their own. I've also tried it on multiple PCs with USB 3.0 or 3.1 ports with the same results.

I'm down to try any advice you can offer. I'm also speaking to Drobo support via email, but they asked me to run Aja System Test, and their instructions don't work with the current version so I've asked them to provide more info.


RE: Drobo 5c is very very slow - Paul - 01-11-2017 06:11 PM

ah ok thanks for checking that hastor,
ok lets see what happens with the system test, and then maybe you could mention the possibility of getting some diagnostics logs generated, and checked by the support team (though please to not try to generate any at the moment in case it conflicts with something just yet)

fingers crossed you can soon get down to the bottom of things, and see quicker access.... (and also to avoid any friendly though slightly cringe-worthy jokes that a certain someone might make Smile like hastor la vista Smile

(looks at dragon) Big Grin


RE: Drobo 5c is very very slow - hastor - 01-11-2017 06:33 PM

Yeah, at this point I think there has to be some odd problem somewhere, but I also know I'm not the only one reporting 15MB/s. I've seen a couple here and a few more in the reviews on Amazon (including mine which I'll raise to 5 stars if this gets sorted).

I'm out of ideas as to what it could be personally, unless a Drobo can just be bad and still work, but slowly. Aside from the speed it is everything I wanted, but that's a major dealbreaker.

I don't know if it has any issues with certain USB ports or something, I've heard of rare cases like that with USB devices. I'm plugging it directly into the motherboard USB 3.1 port of a board with an intel chipset. I think the other PCs may be intel chipsets as well, though I'm not positive. I'd think they'd be common enough to not encounter any issues though, and my HTC Vive supports all the features that it says may need to be disabled on some USB ports, like using the front-facing camera with a high framerate.
Ok, this is kind of odd. I took it over to my 10 year old PC which has a USB 3.0 PCI expansion card I added since the motherboard was 2.0 only. On that PC, it copied to the Drobo at 45 MB/sec - 3 times what I get on this PC, but still really slow. Copying a 1GB file back from the Drobo to the PC was basically instant.

I also tried copying the same files on my new PC to another drive connected to the same USB port, and hit over 100MB/s easily.

Still makes me wonder if there's an issue with intel usb ports especially.


RE: Drobo 5c is very very slow - hastor - 01-11-2017 09:57 PM

Ok, yet another update, but for good reason. I had left the Drobo running with a single 1GB file on it, and went about my life, honestly trying to forget about it for a while. Anyway, I brought it back into my main computer and plugged it in. The files started transferring at over 100MB/s, up to 115MB/s, which is about what I'd expect given the external USB 3.0 5400 RPM drive they are coming from. It dipped as low as 80 but held over 100MB/s for 90% of the time for 16 mins. Then it started dropping. Now I've been seeing it hover around 50MB/s. I'm copying large files of 50GB or so, so there isn't a lot of overhead for creating files.

I was really excited to see it running at full speed. I hadn't changed anything though, same drive config and same USB port, same cable (included one is the only USB-C cable I own). However now I'm a bit disappointed that it slowed down. 50MB/s is still WAY better than the 15MB/s I was getting, but still only half of what I'd expect given the source. The source is 0% fragmented BTW, and the exact same files held over 100MB/s when copied to other drives earlier.


RE: Drobo 5c is very very slow - Paul - 01-16-2017 09:50 PM

hmm this is interesting hastor,
if you had not changed anything maybe it just happend to finish its background tasks...

its cool that youve seen huge increases so far, and maybe you can keep an eye on things to see how things go over the next few days of use etc, and fingers crossed, its ok again.

(one thing worth doing if it does happen again, is to try using dashboard to shut it down, and then shutting down the computer, but then trying to remove any other peripherals that use usb before booting things up again, just in case something was eating up usb bus bandwith or conflicting etc)


RE: Drobo 5c is very very slow - bollwahn - 01-22-2017 08:44 AM

I'm having the same problem. I switched from a Terramaster DAS to drobo because I thought it would be an upgrade.

I'm getting 20-25mb read/write speeds with 5 3tb brand new empty WD RED discs / 1 spare. Via USB3

Any ideas? This speed is unacceptable.


RE: Drobo 5c is very very slow - mariuszj - 01-22-2017 07:24 PM

One more slow crawler here Sad
Red Pro drives in, 20/20 Write/Read speeds. I checked not only mobo USB 3.0's but got a PCI-E express cards to test as well.
Even a PCI-E USB 3.1 card I just plugged in didn't help.
The weird part is - with USB 3.1 card - write starts at 289 MB/s and next second drops to ~40, Read always around 20.


RE: Drobo 5c is very very slow - Paul - 01-23-2017 09:05 AM

hi just to link to bollwhans other post here (with more info about usb monitors too)
http://www.drobospace.com/forums/showthread.php?tid=147466

hi mariuszj, can i check if you are also using some usb monitors?
in the link above, it looks like they were the initial cause of the main slowdown bollwahn described... (a solution still needs to be found for them to be able to use all usb devices if that is the case) though just wanted to check in case you were using them too?


RE: Drobo 5c is very very slow - mariuszj - 01-23-2017 08:35 PM

(01-23-2017 09:05 AM)Paul Wrote:  hi just to link to bollwhans other post here (with more info about usb monitors too)
http://www.drobospace.com/forums/showthread.php?tid=147466

hi mariuszj, can i check if you are also using some usb monitors?
in the link above, it looks like they were the initial cause of the main slowdown bollwahn described... (a solution still needs to be found for them to be able to use all usb devices if that is the case) though just wanted to check in case you were using them too?

Thanks, Paul. No USB Monitors. I've tried every driver I could find for my mobo USB 3.0 and my USB 3.1 card. Nothing helps - the fastest I've got was ~50/20 Write/Read.
Customer Service wants me to go through the RMA process, but I doubt it's the hardware issue...


RE: Drobo 5c is very very slow - Paul - 01-25-2017 08:10 PM

ah i guess if you can do that process as part of the service (and no big cost outlays to you etc) it might be worth doing at some stage if a root cause or solution isnt found...

there was also a recent post here about some usb 3 and usb 3.1 problems too:
http://www.drobospace.com/forums/showthread.php?tid=147303
(maybe you can have a quick look there as well, in case the link i pasted there can find any compatibility warnings for your usb controller?)


RE: Drobo 5c is very very slow - bluyckx - 02-03-2017 01:26 PM

(01-10-2017 07:58 PM)hastor Wrote:  I just got my Drobo 5C, I'm using it for the first time. It is connected to a USB 3.1 port. I'm copying a file that I've copied over the same port to an external HDD at 80MB/s recently (limited by the speed of the external drive). Copying to the Drobo, I'm getting 15-20MB/sec. It is even dipping to 8MB/s and occasionally going down to zero and sitting there for a second before going back up. I'm testing by copying a 50GB file.

I understand they do some self-optimizing when they are new, but I don't think it should be THIS slow. Even in the Drobo Dashboard it shows Write Throughput of 18MB/sec. I would question whether it was getting a proper usb 3.0 connection but even usb 2.0 can do better than this.

I'm running 4 drives - 8TB, 5TB, 750GB, and 250GB. I'll be adding another 5TB once I've backed up the contents on it to the current drives, and will be replacing the 250GB with another 8TB in a month or so. I was just using what I had for now until I can afford bigger drives.

Any advice? At least I can return it if I don't find a solution or see a major improvement in 2 days.

Just a small update - it's been a couple hours since I posted this (and then it had already been long enough to drive me to post about it) and no change. It maybe hits zero less often, but still hovers around 18-21MB/s. I've seen it barely hit 23MB a couple of times, but never once 24 or higher. I even left it unused but on and connected for at least 30 mins to let it catch up with any housekeeping, but it didn't help.

Hi, I'm new to the forum.
I had the same thing (running on windows 10). Check the drivers for your usb. Chances are you still have the 2006 drivers for your USB controllers. Update them manually in device manager. Make sure you include driver updates in your windows update in the future. Visit microsoft's site for details on how to do that. I got this tip from there and it worked immediately.


RE: Drobo 5c is very very slow - Paul - 02-03-2017 04:45 PM

(welcome to the forum) Smile
thanks for the info you found. (i found a few usb drivers that were more recent, though some generic ones at 2006 too)


RE: Drobo 5c is very very slow - bluyckx - 02-04-2017 02:12 PM

(02-03-2017 04:45 PM)Paul Wrote:  (welcome to the forum) Smile
thanks for the info you found. (i found a few usb drivers that were more recent, though some generic ones at 2006 too)

I gathered tha especially the controller drivers were critically for the transfer speed.


RE: Drobo 5c is very very slow - Paul - 02-06-2017 03:16 PM

ok thanks ill make a note for me to check those for future updates (as things work ok for me at the moment i wont try to change them just yet but will make note for future)