Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Chkdsk won't finish on Drobo S
08-06-2015, 10:22 PM (This post was last modified: 08-06-2015 10:56 PM by gvoros.)
Post: #1
Chkdsk won't finish on Drobo S
I am having some problems with my Drobo S on my Media Centre PC.

The main drive on this PC started to give signs of failure about a month ago, and I figured I would wait to reinstall the system until Windows 10 was released, as all my important data was (I thought) safe on the Drobo. Maybe I shouldn't have, as I finally got too many disk read/write errors that the system crashed at some point and flagged the drobo drive as needing a chkdsk as well. Oddly enough this would cause the system to freeze never finish the check on this drive.

I thought no big deal, it's just something to do with the bad system drive; I swapped that out with a new one, clean installed windows 10, but am still having problems with the Drobo S not mounting properly.

The drive lights are all green; 7/10 of the capacity lights are lit which is approximately correct. When the drive is connected properly, drobo dashboard reports no errors.

However, sometimes when I boot with the Drobo powered up already (e.g. a soft reboot of the PC), it won't mount, and the activity light flashes slowly. Drobo Dashboard doesn't detect any Drobos in this state.

If I shut everything down, power up the drobo, then my pc, then connect when everything is all booted up, I can usually mount it again but I get an error about needing to reboot and run chkdsk, although I seem to be able to access everything.

Event viewer shows:

Volume F: (\Device\HarddiskVolume6) needs to be taken offline to perform a Full Chkdsk. Please run "CHKDSK /F" locally via the command line, or run "REPAIR-VOLUME <drive:>" locally or remotely via PowerShell.

If I reboot and let it repair, I get "Scanning and repairing drive (F:): which hangs at 56% (access light on drobo solid on but no disk activity). After about 10 minutes it just gives up and boots into windows, and the drive mounts but is still flagged as needing error checking.

If I run chkdsk /x from an admin command prompt, it finds a few errors with indexes, and at a certain point it seems to hang (once again solid drobo access light), but no further progress / changes on chkdsk progress (usually it keeps a running progress bar). In the event log I get the following message:

WARNING - Reset to device, \Device\RaidPort0, was issued

which seems to happen every 30 seconds for about 10 minutes or so. Occasionally in the mix I get something similar to:

Warning (disk) - The IO operation at logical block address 0x20 for Disk 2 (PDO name: \Device\0000007b) was retried.

and then after a while of this with no further progress, chkdsk simply returns me to the command prompt, without any error or success messages at all. The drive remounts with once again the message that I need to run chkdsk.

The Drobo S is on firmware 2.1.5. I have the latest Drobo Dashboard 2.6.9.

Is the Drobo itself failing? One of the drives? Any suggestions for further troubleshooting?
I seem to be able to access all my files at the moment but am not trusting my Drobo at the moment.... my 1 TB most important things are backed up on Dropbox but I have an additional 6TB of data that I'd rather not lose.

Thanks for any advice the community may be able to offer.

[EDIT] - Actually now I can't get it to mount at all on USB 3.0, only eSATA on another PC. It just does that slow blinky thing with the access light, the volume shows up in My Computer but won't mount or show in Drobo Dashboard. And Disk Management won't load / computer won't shut down or reboot in this state unless I unplug the Drobo. ARGH!
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Chkdsk won't finish on Drobo S - gvoros - 08-06-2015 10:22 PM
RE: Chkdsk won't finish on Drobo S - Paul - 08-07-2015, 03:41 PM
RE: Chkdsk won't finish on Drobo S - Paul - 08-11-2015, 08:20 AM

Forum Jump: