Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Chkdsk won't finish on Drobo S
08-06-2015, 10:22 PM (This post was last modified: 08-06-2015 10:56 PM by gvoros.)
Post: #1
Chkdsk won't finish on Drobo S
I am having some problems with my Drobo S on my Media Centre PC.

The main drive on this PC started to give signs of failure about a month ago, and I figured I would wait to reinstall the system until Windows 10 was released, as all my important data was (I thought) safe on the Drobo. Maybe I shouldn't have, as I finally got too many disk read/write errors that the system crashed at some point and flagged the drobo drive as needing a chkdsk as well. Oddly enough this would cause the system to freeze never finish the check on this drive.

I thought no big deal, it's just something to do with the bad system drive; I swapped that out with a new one, clean installed windows 10, but am still having problems with the Drobo S not mounting properly.

The drive lights are all green; 7/10 of the capacity lights are lit which is approximately correct. When the drive is connected properly, drobo dashboard reports no errors.

However, sometimes when I boot with the Drobo powered up already (e.g. a soft reboot of the PC), it won't mount, and the activity light flashes slowly. Drobo Dashboard doesn't detect any Drobos in this state.

If I shut everything down, power up the drobo, then my pc, then connect when everything is all booted up, I can usually mount it again but I get an error about needing to reboot and run chkdsk, although I seem to be able to access everything.

Event viewer shows:

Volume F: (\Device\HarddiskVolume6) needs to be taken offline to perform a Full Chkdsk. Please run "CHKDSK /F" locally via the command line, or run "REPAIR-VOLUME <drive:>" locally or remotely via PowerShell.

If I reboot and let it repair, I get "Scanning and repairing drive (F:): which hangs at 56% (access light on drobo solid on but no disk activity). After about 10 minutes it just gives up and boots into windows, and the drive mounts but is still flagged as needing error checking.

If I run chkdsk /x from an admin command prompt, it finds a few errors with indexes, and at a certain point it seems to hang (once again solid drobo access light), but no further progress / changes on chkdsk progress (usually it keeps a running progress bar). In the event log I get the following message:

WARNING - Reset to device, \Device\RaidPort0, was issued

which seems to happen every 30 seconds for about 10 minutes or so. Occasionally in the mix I get something similar to:

Warning (disk) - The IO operation at logical block address 0x20 for Disk 2 (PDO name: \Device\0000007b) was retried.

and then after a while of this with no further progress, chkdsk simply returns me to the command prompt, without any error or success messages at all. The drive remounts with once again the message that I need to run chkdsk.

The Drobo S is on firmware 2.1.5. I have the latest Drobo Dashboard 2.6.9.

Is the Drobo itself failing? One of the drives? Any suggestions for further troubleshooting?
I seem to be able to access all my files at the moment but am not trusting my Drobo at the moment.... my 1 TB most important things are backed up on Dropbox but I have an additional 6TB of data that I'd rather not lose.

Thanks for any advice the community may be able to offer.

[EDIT] - Actually now I can't get it to mount at all on USB 3.0, only eSATA on another PC. It just does that slow blinky thing with the access light, the volume shows up in My Computer but won't mount or show in Drobo Dashboard. And Disk Management won't load / computer won't shut down or reboot in this state unless I unplug the Drobo. ARGH!
Find all posts by this user
Quote this message in a reply
08-07-2015, 03:41 PM (This post was last modified: 08-07-2015 03:44 PM by Paul.)
Post: #2
RE: Chkdsk won't finish on Drobo S
hi, as i was reading your post, a few things came to mind..

eg, sometimes even on windows 7, a chkdsk from command prompt can seem to stall (such as on my drobo-s) but usually its near the very end step of the chkdsk process.... but if i wait long enough i think 90% of the time, it completes fine.

i think in your case there are a few variables involved that might be affecting things...


1) if you can power all down, and unplug the connection from drobo to computer, and then just power up the drobo, can you describe what happens when drobo boots up? (eg progress, and all lights?)

2) if boot sequence is all ok and lights as expected, then it could be the computer crashing which affected the filesystem on the drobo. (assuming nfts?) in which case chkdsk seems the next logical step...but..

3) now that you have windows 10, that adds a whole new variable to the mix, eg compatibility, and support of the connecting cable... which also..

4) could be a connection port or physical cable issue as well.

do you have a windows 7 bootdisk that you could try booting up in safemode with command prompt, just to see if it can recongnise your drobo without issue? if your drobo shows up as drive letter B (for example)

if so, maybe you could try running a "chkdsk b:" on it,
see what that reports
+
then you could try a "chkdsk b: /x" to attempt to fix things
and see what that reports. (you might need to run this way a few times, until it gives you a "no errors found" message)
edit: if your other computer is windows 7, maybe you could try that in safe mode too

(btw i have XP home SP2, a Drobo v1 with 2x 1TB/2x 1.5TB WD greens, & a bkp Drobo v2 with the same + a DroboShare: unused)
& a DroboS v2 with 3xWD15EADS &2x1TB in DDR mode on win7, & a drobo5D (all usb)
  • btw i did a sustained (write) operation for about 6 hours, and got 13.2MB / sec ...objection? "sustained" :)
    (16.7MB/s on a v2 & 47-96MB/s drobo-s)
Find all posts by this user
Quote this message in a reply
08-10-2015, 04:32 PM
Post: #3
RE: Chkdsk won't finish on Drobo S
Thank you for your suggestions. I was away for the weekend, and now am back trying to get this fixed.

So on boot of the Drobo, all the lights come on
Drive lights are yellow

After a few seconds, the activity and capacity lights all go off. The capacity lights - rightmost 3 light up pretty quick, the rest more slowly.

Then all the lights go off. Drive bays all light up green. Capacity lights very slowly fill up from left to right until 6 are lit, then the drobo goes to sleep (fans shut off, power light turns yellow).

It's at this point when I plug it into USB 3.0 the activity light just slowly blinks. Capacity lights actually go from 6 -> 7 lit up. Drobo shows up as a drive on my pc (as Local Disk (FSmile )but no filesystem info, no volume label (e.g. no NTFS) and does not mount. Drobo dashboard does not detect it as a drobo. Sometimes if I leave it for 1-2 hours, dashboard will pick it up (without any error messages, says status is OK) but it still doesn't mount. the PC itself in this state is unstable (i.e. if I try to install a program, it hangs. Won't shut down properly, and other weirdness) until I power off / disconnect the Drobo.

This is the case in Windows 10 and Windows 7, exact same behaviour.

with eSATA, it mounts (but the drive is marked as needing a chkdsk as described above, which hangs at 56%).

Interestingly enough, Drobo Dashboard reports the "active interface" as iSCSI. Not sure if that's supposed to be the case when I am using an eSATA cable....

I am in the process of getting all the data off this thing (a few expensive HD purchases later...) maybe a reformat will fix it? Not sure.
Find all posts by this user
Quote this message in a reply
08-11-2015, 08:20 AM
Post: #4
RE: Chkdsk won't finish on Drobo S
hi thanks for more info,

as it sounds like you are able in some way to mount and copy data somewhere else, then i think you might as well carry on as you are, as a backup etc.

if you do encounter problems with copying data, maybe you could try this from a safemode point of view?
eg, sometimes over time, windows will have lots of things running in the background, eg services for google, samsung, apple, indexing utils etc etc, and all these programs can also cause slowdowns etc all round. i think safemode just load the main windows components, and you can double check via start >> run > services.msc to see what is running.

the only other idea at the moment is to try a different usb cable and a different usb slot, just in case that helps but as mentioned first, if you are currently backing up your data and its working, then might as well carry on with that for now.


(for the hard drive prices, i know what you mean - i recently bought a brand new wd15eads 1.5tb drive to replace the one that failed after 4-5 years for my drobo gen1, and while i bought it originally for about £42 or similar, it took me a fair while to find one for about 75 and most were being sold refurbished for about 150). i also looked at prices for wdred 6gb just to see, and they were over £200 each - so ill be waiting a while until i fill up my new 5d with drives Big Grin

(btw i have XP home SP2, a Drobo v1 with 2x 1TB/2x 1.5TB WD greens, & a bkp Drobo v2 with the same + a DroboShare: unused)
& a DroboS v2 with 3xWD15EADS &2x1TB in DDR mode on win7, & a drobo5D (all usb)
  • btw i did a sustained (write) operation for about 6 hours, and got 13.2MB / sec ...objection? "sustained" :)
    (16.7MB/s on a v2 & 47-96MB/s drobo-s)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: