Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
B1200i is unfit for real work environments
09-08-2016, 04:08 PM
Post: #1
B1200i is unfit for real work environments
I work at a research facility. We crunch on BIG Linux High Performance Clusters. We store data on BIG Linux file systems. Our servers are all BIG Linux servers. And we do it all from our Linux laptops and workstations.

I was in a meeting a few weeks ago and a researcher said "I need 50-60TB cheap. Don't care if it is fast or slow, just cheap. Preferably redundant." Well, (8+) years ago there was a Drobo 2nd gen in the server room. Drobo-utils was great and we did everything we needed off of an Ubuntu (later Scientific Linux) box. But that was when 8TB was a lot. We out grew the device and it eventually disappeared as we were dealing with storage on the order of 100's of TBs. I told them that they should research Drobo and I left for vacation.

Came back today after having been gone to find a B1200i and a stack of hard drives at my desk...

Problem #1:
I racked the Drobo and fired up an Ubuntu laptop, plugged into the iscsi and could NOT get drobo-utils to see the device. Finally I found a post saying "You actually /have/ to have the Drobo Management software to initially configure a B1200i." That software is only for Mac and Windows. What. The. Hell? I don't play games at work so why would I need a Windows box? I don't even know what you use a Mac for...guess I am not hipster enough...

I went and asked the other techs in the data center. Their response? "Why the Fu** would we have those OS's?" A great question indeed.

Eventually one of them dug up a personal laptop "I think this has Windows something on it. It might boot..." Yup! Awesome.

Annoyance #1
That interface is slow! There were plenty of resources available so I know it wasn't waiting on CPU/Mem/network. Other apps seemed pretty responsive...You've already put me in a bad mood having to dig up a crap OS to use your utility. Having it be slow and annoying doesn't help.

Annoyance #2
Once I created a volume, I can't name it UNLESS I format it NTFS! Seriously, what brain damaged designer came up with that? A bunch of LUNS all labeled "Drobo"?? Fine. I will create them and name them with NTFS, the wipe and remount it as something else....Except the name disappears when you do that. Fuuuuuuuu.............Whatever. It is a good thing I am not planning on having a lot of LUNs

Problem #2
I finally created LUN and logged into the Red Hat 6.7 box. I ripped through the iSCSI setup, ran parted, and configured it. That was easy, then again that was just Linux. However, then I went to format it and got a weird error with ext4. Off to the internet! What. The. Fu**? EXT4 isn't supported? My particular error was flagged as a known problem and the "solution" was to not use ext4. Ext4 has been around almost as long as Drobo the company has been. How is it not supported??

Problem #3
http://support.drobo.com/app/answers/det...http://support.drobo.com/app/answers/detail/a_id/29/~/which-file-systems-do-drobo-storage-devices-
My choice options are:
HFS+ : Um. No.
NTFS : Anyone who understands filesystems and has seriously looked at NTFS knows you DO NOT store anything you believe to be important on NTFS. Sure it is "better" now then a few years ago, but the underpinnings are still just as bad....*shudder*.
Fat32 : Hahahahaha. Seriously? Is that a joke? A typo? I don't even use FAT on my USB thumb drives! It is a terrible relic of the 80's/90's and it should stay there.
EXT3 : Um. OK. Why not something newer?
VMFS : Not relevant to me.

So my only options are 16TiB limited ext3?? Has Drobo not advanced their filesystems in 10 years?? What the hell am I supposed to do with a bunch of 16TiB LUNs? A quick search online about running LVM across the LUNs shows that it seems to be a not-a-recommended strategy so I can't join the 16TiB LUNS. It *literally* is completely useless to me. There isn't a single use case in my entire server room where a 16TiB iSCSI LUN is useful.

I have a lot of work to do and a lot to catch up on. I pissed away 3hrs of my day on this and no more. I packed that sh*t up and kicked it the Fu** out of my server room. Told them to return it back to where it came from and to be sure to get their money back.

I have weekly meetings with people around the country who are doing what I do (some bigger; some smaller). ONE of them has a few Windows servers for gateways to support the few client researchers who use Windows (aka: university professors). There is a very good reason why Windows has <0.4% of machines on the top 500 supercomputers (and Apple's don't show up at all). The numbers don't go up when you expand to the top 1000 either. Those OS's can't handle real work loads.

The B1200i is unfit for real work environments to any useful capacity. I am very disappointed and incredibly sorry that I recommended Drobo.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: