Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Crashplan problem
03-13-2013, 04:51 AM
Post: #1
Crashplan problem
have been using crashplan for ages quite happily but it seems to have broken recently and I think it may be to do with a client driven upgrade of the server. Crashplan has autoupgraded my Mac to v 3.5.2 and when I connected it to headless DroboFS crashplan server is said something about upgrading, waited for about 2 mins and then exited.

The engine_error.log now says:-
Error: Could not find or load main class com.backup42.service.CPService

whenever I try to restart the crashplan serve on the DroboFS.

This is the log from engine_output.log - I think the client connected somewhere between 2:48 and 2:51.

[03.13.13 02:48:38.733 INFO main root ] NO customizations found.
[03.13.13 02:48:38.734 INFO main root ] END Copy Custom
[03.13.13 02:48:38.766 INFO main root ] Loading from default: /mnt/DroboFS/Shares/DroboApps/crashplan/app/conf/default.service.xml
[03.13.13 02:48:39.679 INFO main root ] Loading from my xml file=conf/my.service.xml
[03.13.13 02:48:40.157 INFO main root ] Loading ServiceConfig, newInstall=true, version=3, configDateMs=null, installVersion=1349845200340
[03.13.13 02:48:40.158 INFO main root ] OS = Linux
[03.13.13 02:48:41.097 INFO main root ] AuthorityLocation@5519953[ location=central.crashplan.com:443, hideAddress=false ]
[03.13.13 02:48:41.106 INFO main root ] Config already has a value for Java memory heap max; mx=512m
[03.13.13 02:48:41.107 INFO main root ] END Loading Configuration
jtux Loaded.
[03.13.13 02:51:48.958 INFO MQ-Peer-2 root ] DownloadManager stopped.
[03.13.13 02:52:09.791 INFO W28161952_DwldMgr root ] DownloadManager stopped.
[03.13.13 02:52:29.683 INFO W28161952_DwldMgr root ] ***** STOPPING *****
[03.13.13 02:52:29.688 INFO Thread-0 root ] Stopping service...
[03.13.13 02:52:29.958 INFO Thread-0 root ] Selector shutting down...
[03.13.13 02:52:29.959 INFO Sel-UI-A root ] SelectorEngine stopped.
[03.13.13 02:52:29.960 INFO Thread-0 root ] Selector shutting down...
[03.13.13 02:52:29.960 INFO Sel-UI-C root ] SelectorEngine stopped.
[03.13.13 02:52:29.961 INFO Thread-0 root ] Selector shutting down...
[03.13.13 02:52:29.962 INFO Sel-UI-R root ] SelectorEngine stopped.
[03.13.13 02:52:29.963 INFO Thread-0 root ] Selector shutting down...
[03.13.13 02:52:30.047 INFO Sel-UI-W root ] SelectorEngine stopped.
[03.13.13 02:52:30.050 INFO Thread-0 root ] [Factory 672288]stop() Stopping
[03.13.13 02:52:30.051 INFO Thread-0 root ] UISession stopped.
[03.13.13 02:52:30.054 INFO Thread-0 root ] PG::DefaultGroup Stopping RemotePeerList. Stopping workers and removing all peers. #peers=1, location=[558672784081240452@0.0.0.0:4242]
[03.13.13 02:52:30.267 INFO W26989360_PeerTimeou root ] PeerConnector.TimeoutWorker stopped.
[03.13.13 02:52:30.267 INFO Thread-0 root ] PeerConnector closed.
[03.13.13 02:52:30.274 INFO Thread-0 root ] Selector shutting down...
[03.13.13 02:52:30.274 INFO Sel-Peer-A root ] SelectorEngine stopped.
[03.13.13 02:52:30.275 INFO Thread-0 root ] Selector shutting down...
[03.13.13 02:52:30.276 INFO Thread-0 root ] Selector shutting down...
[03.13.13 02:52:30.277 INFO Sel-Peer-R root ] SelectorEngine stopped.
[03.13.13 02:52:30.278 INFO Thread-0 root ] Selector shutting down...
[03.13.13 02:52:30.279 INFO Thread-0 root ] [Factory 14452816]stop() Stopping
[03.13.13 02:52:30.282 INFO Sel-Peer-C root ] SelectorEngine stopped.
[03.13.13 02:52:30.284 INFO Sel-Peer-W root ] SelectorEngine stopped.
[03.13.13 02:52:30.396 INFO Thread-0 root ] PeerController stopped.
[03.13.13 02:52:30.419 INFO Thread-0 root ] Backup torn down.
[03.13.13 02:52:30.420 INFO Thread-0 root ] DownloadManager stopped.
[03.13.13 02:52:30.422 INFO Thread-0 root ] SystemWatcher stopped.
[03.13.13 02:52:30.423 INFO Thread-0 root ] Service stopped

Thanks in advance for any help

Andy
Find all posts by this user
Quote this message in a reply
03-13-2013, 06:25 AM
Post: #2
RE: Crashplan problem
Further to this, I'm pretty sure I'm correct as I've managed to prevent the automatic update by putting the following entry in /etc/hosts

127.0.0.1 download.crashplan.com

it doesn't try to upgrade now and therefore doesn't break itself.

looking forward to a drobo port of release 3.5.2 now...

Andy
Find all posts by this user
Quote this message in a reply
03-13-2013, 06:27 AM
Post: #3
RE: Crashplan problem
Oh, I noticed that one as well. Long story short: the upgrade script does not work with busybox (which is what the FS uses) and therefore nukes itself.

To fix it login to you FS and type this:
Code:
cd /mnt/DroboFS/Shares/DroboApps/crashplan/app/upgrade/1360908000352.1362996098281
If that folder does not exist, then there should be a similar one, i.e., /mnt/DroboFS/Shares/DroboApps/crashplan/app/upgrade/<large number>.<other large number>

In that folder there is a file called upgrade.sh. That file begins with this:
Code:
#!/bin/sh

# commands, NOTE that the options are different based on OS/shell
RM="rm -fv"
MV="mv -fv"
What you have to do is change the RM and MV lines to this:
Code:
RM="rm -f"
MV="mv -f"
In other words, remove the "v" option. That option is not supported on busybox, and thus not supported by the FS.

This should be enough to complete the upgrade, but it will fail to restart the Crashplan service. That is ok. Just CTRL+C the upgrade once it complains about "ps" not understanding the option "-e" (also a bug in their script), and then manually restart Crashplan using service.sh.

As soon as I have some free time I'll update the Crashplan DroboApp.

If you do have some time, then please open a support ticket with Crashplan and ask then to support Busybox-based Linux systems. The way I packaged Crashplan should allow for transparent upgrades, as long as their upgrade script understands the limitations of busybox.

Tap the full potential of the Drobo FS/5N with DroboApps.
To receive the latest updates about my DroboApps circle me on Google Plus.
Find all posts by this user
Quote this message in a reply
03-14-2013, 11:44 PM
Post: #4
RE: Crashplan problem
Followed your steps Ricardo, but I am not getting any message or anything about "ps" not understanding anything. The crashplan software just quits. I try and restart the service.sh, and it says it is starting locale, then bash. But when I try and start the software again on my Windows 7 machine, it just says "Unable to connect to the backup engine, retry?".

What should I do now?

Adam
Find all posts by this user
Quote this message in a reply
03-15-2013, 03:13 AM
Post: #5
RE: Crashplan problem
I think I did not make clear enough: did you run the upgrade.sh script once you fixed it? That should put the files in their correct place.

Tap the full potential of the Drobo FS/5N with DroboApps.
To receive the latest updates about my DroboApps circle me on Google Plus.
Find all posts by this user
Quote this message in a reply
03-15-2013, 11:46 AM
Post: #6
RE: Crashplan problem
Ok. I just tried to run the upgrade.sh script but was given the message "permission denied". Do I have to run the script in a special way?
Find all posts by this user
Quote this message in a reply
03-15-2013, 12:01 PM
Post: #7
RE: Crashplan problem
You have to run it as root.

Tap the full potential of the Drobo FS/5N with DroboApps.
To receive the latest updates about my DroboApps circle me on Google Plus.
Find all posts by this user
Quote this message in a reply
03-15-2013, 12:04 PM
Post: #8
RE: Crashplan problem
Got past the permission denied part (I was trying to run the script using start command instead of sh) but crashplan still will not start when I run service.sh. I try and stop it or restart it and it says "crashplan is not running".
Find all posts by this user
Quote this message in a reply
03-18-2013, 08:38 AM
Post: #9
RE: Crashplan problem
What is the content of "/mnt/DroboFS/Shares/DroboApps/crashplan/var/log/engine_error.log"?

Tap the full potential of the Drobo FS/5N with DroboApps.
To receive the latest updates about my DroboApps circle me on Google Plus.
Find all posts by this user
Quote this message in a reply
03-21-2013, 11:06 AM (This post was last modified: 03-21-2013 11:06 AM by pmagid.)
Post: #10
RE: Crashplan problem
I am having the same problem...
Here is the content of my "/mnt/DroboFS/Shares/DroboApps/crashplan/var/log/engine_error.log":


Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Error: Could not find or load main class com.backup42.service.CPService
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: